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A Computer Based Accessible Receptive Language Assessment

Implementation Guide  

(How to carry out the assessment)

Version 1.  12th March 2015

CARLA is a Devices for Dignity Product, created by Andrea Kirton and Simon Judge from the Barnsley Hospital Assistive Technology Team.

http://www.techcess.co.uk/carla/
Overview
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CARLA is a Mind Express document.

CARLA is a receptive language assessment based on the Mind Express software.  You open CARLA within Mind Express as a Mind Express document.
You have to set CARLA up for a user
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CARLA can be set up to be accessible to any child able to use an alternative access method such as a switch, eye gaze, joystick, mouse etc.  
Part of CARLA can also be setup with individualised content for a child, if they are not yet at the stage where they will be able to complete any of the sections of the main assessment.

You have to start a new session when working with a user 
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CARLA works on a session basis. For each user (child) you have to start a new session, carry out the assessment (or part of it) and then save (export) the results.
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You have to save results from each session

If you do not export the results from a session, they will be lost. You can save them as a simple text file on a memory stick or on your computer/network.
You have to look at the results using the spreadsheet template
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Once you have saved the results you can look at them using a simple excel file – this will allow you to look at overall performance and in more depth, for example at specific errors.
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Step by Step Guide

Things to consider before beginning the assessment
a. You should familiarise yourself with the assessment, the subcategories in it and how to navigate between them.

b. A quiet room should be allocated for the assessment and all possible distractions should be minimised.

c. A time should be selected for the assessment which takes into account factors such as tiredness and the child missing a favourite activity.
d. If the child has specific computer access needs (see the resource guide for information on access method considerations) then Mind Express should be set up to replicate the child’s established access method (see below). 

e. If you are only intending that the child carry out certain subcategories, you should list these in advance (you can use the record sheet at the back of the resource guide).
Prepare
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Open the CARLA document:
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Open Mind Express by clicking on the desktop icon. 
Open the CARLA document by choosing: File->Open.  Choose the CARLA folder and then the CARLA document.
2. Explore CARLA: 

The assessment will immediately be ready for you to explore. You can go in and out of the subcategories or to familiarise yourself with the layout of the assessment. It is fine to explore the assessment in this way - just make sure you start a new session before you see a new child. 
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The assessment is designed to either be started from the beginning (the Pre-assessment Access Check) and worked through in order to the end; O or for you to go in and out of subcategories as you require using the main menu page.

3. Setup CARLA (Mind Express) for the child:

Change the relevant options within Mind Express to ensure the assessment is correct for your child. See the sections below with more detail on how to change each of these settings.
· Access Method (Mouse, Switching, Joystick)
· Voice output (i.e. choose a synthesised voice that the child understands and will respond to, changing speed and volume). 
· You can plug a speaker into the computer, or the child can use headphones if required.

· Visual Contrast (colours, border, spacing)

· Using it with a bigger screen (or interactive whiteboard) 

4. Start the CARLA session:
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Once you are ready to start the Assessment with the results being recorded, click Start New Session and confirm your choice.

Carry out the Access Test
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Start the Preliminary Access test

Click on the access check button using the touchscreen or mouse.
2. Instruct child to select the yellow star.
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Or show them the picture card at the back of this manual and ask them to find the one which is the same.
“Show me which is the same”

You can support this by pointing to the coloured square or with any other verbal prompts as at this point we are not testing comprehension at this point but are testing if the child can access the screen. 

3. Do not proceed if the child does not pass the access test.
The child must score 6/6 in order to know that their access method is accurate enough to continue with the assessment. If they have made an error in the access assessment then it may be that errors made later on are due to access rather than comprehension so would not be a valid comprehension assessment.

Carry out the main assessment  

At the Beginning of the assessment
1. The child should be informed that they will be asked to listen to some questions and to select the answer they think is right. 
“You will hear a question.  Choose the one you think is right”

2. They should be told that they can let you know if there is a problem, if they need it repeating or if they need a break or to stop. 
They should also be told that if they don’t know the answer they can either let you know or choose the one they think is most likely.

“ Let me know if you want to stop”

3. The child should also be reassured.

You can tell the child that the assessment is just for the assessor to find out what they know and don’t know and they won’t be told off if they get any wrong.
“You will not be told off if you get something wrong”
4. Clarify that there is no time restriction

Children are used to playing computer games with a speed element. It is important to stress that there is no speed element to this activity and they have as long as they want to select their answer.

“There is no rush”

Carrying out the Assessment
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The assessment should then be completed  (ideally in order)

You can do the whole assessment in order by clicking ‘Continue’ at each opportunity.

Although it may be tempting to skip some subcategories where the assessor feels sure of the child’s skills and only do the subcategories they feel less sure of, it is clinically good practice to complete the full assessment to get a clear profile of the child’s abilities and any gaps. 
It will not have any adverse effect on the child if they have to complete sections which they find easy but will confirm the assessor’s opinions and provide a more complete picture. 
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The assessor or the child can select the question mark 
This will play the question. Each screen is laid out in the same format with the question mark in the top left of every screen.
7. The child should then select their answer
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They should use their chosen access method. The computer will record this selection.
8. If the child needs the question repeating they can select the question mark again. 
The computer will record how many repetitions were needed for the questions.
9. Choose the next questions in the subcategory.
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When the ‘next questions’ arrow appears, the assessor should choose this in order to proceed to the next set of questions in the subcategory.

The assessor does not need to record the results but just needs to make a note of any extra factors which may affect performance on the record sheet. 
10. At the end of each subcategory, the child can choose the ‘reward’ icon.
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The assessor can choose to continue or return to the main menu
Navigating home will allow the assessor to navigate to a different subcategory or to stop the assessment.

Choosing next moves to the next part of the assessment.

Restart will allow the sub-category to be repeated if felt necessary.
12. Taking breaks

Throughout the session, the results are stored, so it is fine to take breaks.

You can also split the assessment over days - as long as Mind Express is not used in any other way in between sessions (see ‘Saving’ below).
During the Assessment

The person administering the assessment should adhere to the following guidelines:

1. The child should be comfortable, engaged, looking at the screen and listening before the assessment begins.

2. No verbal prompts should be given by the assessor. 
General encouragement such as “you are being very good” ore reminders of the end reward can be given if needed.

“you are being very good”

3. No physical prompts, such as pointing to an area of the screen, should be used.

4. The question should not be spoken by the assessor or repeated or reworded.

5. Use the record sheet

Any extraneous factors affecting the results should be noted  on the record sheet. If an external factor means the assessment item needs repeating, for example an alarm sounding, then this should be noted. These notes can be added to the electronic results (excel sheet) after completion.

6. No indication of whether the answer was correct or incorrect should be given to the child. 
The child should be encouraged with general phrases but should not be given feedback about their specific responses.

“you are doing well” , “good looking”, “this is fun”

7. The child can use their normal communication methods to communicate their needs to the assessor

for example if they are uncomfortable or too tired to continue, but they can not ask the assessor about the assessment answers. 

8. If the child indicates that something is wrong 
If the child indicates that something is wrong with the assessment, for example that they gave the wrong answer, then this should be noted.

9. If the child asks for help

If the child indicates that they do not know the answer and are asking for help, they should be reassured that it’s ok to just choose the one they think the most likely and it won’t matter if it is wrong.

After the Assessment
10. The child should be rewarded 
for their cooperation, their attempt to complete the assessment or their achievements in that session regardless of their score.

11. The assessor should look at the scores only once the child is out of the room.

12. A six month interval is recommended between testing in line with clinical practice.

Saving the Results

You must save the results of the assessment after each session.

1. Go to the Main Menu page
Either by navigating within the assessment, or pressing the ‘Home’ key on a keyboard.

2. Choose ‘End Session – Save Results’
3. Choose ‘Save your Results’
Save the results file in an appropriate location with an appropriate name (e.g. JoeA-IDnumber-10Dec14.txt)

4. Open the Excel Analysis Sheet

Open Excel and open the CARLA spreadsheet.

5. Import and test the results file

Choose the import button and browse to the results file you saved in step 3.  Choose ‘Open’ to import this.
6. Reset the assessment

After you have saved the results, and tested that they import without problem into Excel then you can reset the assessment for the next user/session.
In Mind Express, click the Reset button and then confirm your choice.
Viewing and Interpreting the Results

1. The results can be viewed using Excel. 
To do this, first open excel and open the CARLA results sheet.
If a box appears asking if you wish to ‘enable macros’ choose yes or ‘Enable Content’. This may also appear as a bar at the top of the sheet.
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2. Import the results file

Choose the import button and browse to the results file you wish to view (e.g. JoeA-IDnumber-10Dec14.txt ).  Choose ‘Open’ to import the file.

3. You can use the ‘next button’ or the tabs at the bottom of the sheet to navigate through the results.  
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4. You can use the drop down arrows to look at results for specific subcategories.
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5. Interpret the results with care.

The results are indicative and this is not a standardised assessment.  See the Resource Manual for information around interpreting the results.
Specific Help

1. Setting the Access Method (Mouse, Switching, Joystick)
Press the Esc key on a keyboard if you can not see the MindExpress Menu.

· Click on: Edit -> Mouse

· Click on: Mouse, Joystick or Scanning to select the access method you want to use. 

To edit specific settings (for example a scan speed):

· Click on: Tools

· Choose ‘Mouse selection…’, ‘Joystick selection…’ or ‘Scanning selection…’ depending on what access method you wish to configure to best suit the needs and skills of the user.

For more information about editing access methods or settings, see the MindExpress manual. 
2. Choosing a voice

Choose a synthesised voice that the child understands and will respond to, changing speed and volume.
· Press the Esc key on a keyboard if you can not see the MindExpress Menu.

· Click on Tools -> Speech 
· Select the voice you want to use. Change the volume and speed of the voice.
3. Visual Contrast (colours, border, spacing)

· Press the Esc key on a keyboard if you can not see the MindExpress Menu.
· Press F2 to go to the Edit mode
· Click Document ->Style settings
· The style used for the main assessment cells is ‘Answer Cell’.
· Choose the style to change the colours, border, font, image size and text position.
Frequently Asked Questions
1.  I can not hear anything

Your computer may be muted, or the volume turned down. Check the computer settings.

The speech settings in MindExpress may be wrong:

· Press the Esc key on a keyboard if you can not see the MindExpress Menu.

· Click on Tools -> Speech 
· Check a voice is selected. 

· Check the volume is not too low (set it to 100). 

2. The access test says ‘failed’ but I am sure the child got the answers correct

Did you press the question button before each response?   If you did not do this, the results will not have been recorded correctly.  As with the rest of the assessment, you need to press the question button (‘Can you find the star like this?’) before the child presses the answer.

Adaptations for Children with Additional Needs

This assessment has been designed so that it can be adapted to allow children with additional needs to access it. It is expected that the child’s normal access method and adaptations should be used; however suggestions are made below as to what should be considered.

Children with Physical Disabilities

This assessment has been designed to work with the range of access methods most commonly used by children with physical disabilities. The child should use the method that they use for other activities, for example, with educational resources, computer access, or communication systems. 

This assessment is not designed to determine the effectiveness of an access method or to compare different access methods. The access method must be in place and reliable before they use it for the assessment otherwise it will be impossible to tell if errors are due to physical access or comprehension difficulties. 

Any of the access methods available within the software can be used, including:

· Single switch ‘auto’ scanning

· Two switch ‘user’ scanning

· Joystick or ‘directional’ scanning access

· Headmouse or other alternative mice

· Eye gaze selection (with either dwell or switch to select)

Other features that may also facilitate more effective access can be used, including:

· Keyguards or keyguides (on request from the supplier)

· Touch screen settings such as sensitivity, touch enter, touch exit

Only non partner facilitated methods should be used where possible to avoid the possibility of interpretation or other bias.
Children with Hearing Impairment

The assessment usually relies on responses to questions spoken by the computer. If the child is unable to hear the questions then strategies to augment this such as noise cancelling headphones, additional speakers or hearing loops can be used.

If the child is unable to hear any spoken language and requires signing support then the assessment can still be used but the assessor needs to clearly identify what they are assessing. They are no longer assessing auditory receptive language comprehension but are assessing signed or lip-read receptive language comprehension. 

It is essential that the questions are all signed exactly as they are spoken and that no additional information is given. 

Further signed versions may be made available in future if there is a demand for this.

Children with Learning Disabilities where Signing is used for Language Support

The option of signing support could also be used for those children with learning disability who use signing support in everyday life. Again, in these cases, it must be noted that the skill being assessed is verbal comprehension with signing support and not pure verbal comprehension. It may be tempting to compare these children’s skills with and without the signing support. This should not be done however due to the learning effect of completing the assessment.           
Children with Visual Impairment

The assessment can be played back on a large monitor, positioned at the optimum angle for the child’s vision or completed on an interactive whiteboard. 

The colour contrasts of the backgrounds, the highlighting of selected squares and the scanning colours can all be changed to suit individual needs [REF TO MANUAL]. The pictures could also be separated out with thicker borders and with gaps in between. A large cursor can also be selected. This level of editing may require technical support which can be provided by the supplier.

A keyguard may also help if the difficulty is around hand-eye coordination. This can be requested from the supplier. The screen size will need to be provided.
Children with Attention Difficulties

The assessment is broken into short subcategories and uses visually bright materials in an attempt to capture the child’s attention. If the child is unable to complete a subcategory, it can be paused and restarted as necessary. These children may prefer the assessment on a touch screen or on a large monitor to hold their attention. 

Sound effects can be added after each question to maintain the child’s attention. This can be selected for any children who may prefer this or left out for children who may find it distracting.

Resistant or Uncooperative Children

Rewards can be built into the computer based activity such as video clips, music clips or games. A child who is uncooperative due to demand avoidance or due to lack of confidence may prefer to complete the assessment when left by themselves. This could be videoed or observed through a one way screen in order to capture any additional information of extraneous factors which may have affected the results.
A reward icon appropriate for the child can be selected at the start of the assessment. The child will be awarded one of these at the end of every subcategory they complete and an animation in the same theme once they complete the assessment.
Further adaptations could be made for specific case however these would need to be in line with the principles and ethos of the assessment. The child must not be given additional verbal or non verbal help to respond to the questions. 

Included
Star Card:

Example of a full page yellow picture which can be shown to child to show what they need to select in the Pre-assessment Access Test. This is to ensure it is a matching test which requires even less comprehension

Record Card:
Assessment index with space to write comments by each assessment item.


CARLA Record Card / Index

Note, the order of the questions within each sub test will vary – the questions are ‘shuffled’ each time CARLA is run.

	CATEGORY
	SUBCATEGORY/PAGE
	QUESTION
	TARGET
	NOTES

	Access
	Access Method
	Find the star like this
	Yellow star
	

	Vocabulary


	Vocabulary - Early
	Shoes
	Shoes
	

	
	
	Ball
	Ball
	

	
	
	Book
	Book
	

	
	
	Cup
	Cup
	

	
	
	Sock
	Sock
	

	
	
	Bed
	Bed
	

	
	
	Banana
	Banana
	

	
	
	Car
	Car
	

	
	Vocabulary – Topics 1


	Trousers
	Trousers
	

	
	
	Coat
	Coat
	

	
	
	Hat
	Hat
	

	
	
	Shoes
	Shoes
	

	
	
	Rainy
	Rainy
	

	
	
	Snowy
	Snowy
	

	
	
	Rainbow
	Rainbow
	

	
	
	Sunny
	Sunny
	

	
	
	Rabbit
	Rabbit
	

	
	
	Fish
	Fish
	

	
	
	Dog
	Dog
	

	
	
	Hamster
	Hamster
	

	
	
	Giraffe
	Giraffe
	

	
	
	Monkey
	Monkey
	

	
	
	Lion
	Lion
	

	
	
	Elephant
	Elephant
	

	
	
	Cow
	Cow
	

	
	
	Chicken 
	Chicken 
	

	
	
	Pig
	Pig
	

	
	
	Sheep
	Sheep
	

	
	Vocabulary - Topics 2
	Car
	Car
	

	
	
	Train
	Train
	

	
	
	Boat
	Boat
	

	
	
	Digger
	Digger
	

	
	
	Doll
	Doll
	

	
	
	Balloon
	Balloon
	

	
	
	Pen
	Pen
	

	
	
	Teddy
	Teddy
	

	
	
	Banana
	Banana
	

	
	
	Chocolate
	Chocolate
	

	
	
	Biscuit
	Biscuit
	

	
	
	Crisps
	Crisps
	

	
	
	TV
	TV
	

	
	
	Chair
	Chair
	

	
	
	Table
	Table
	

	
	
	Bed
	Bed
	

	
	
	Fairy
	Fairy
	

	
	
	Dinosaur
	Dinosaur
	

	
	
	Monster
	Monster
	

	
	
	Pirate
	Pirate
	

	
	Vocabulary - Adjectives 
	Big
	Which one is big
	

	
	
	Little
	Little
	

	
	
	Sad
	Sad
	

	
	
	Happy
	Happy
	

	
	
	Wet
	Wet
	

	
	
	Dry
	Dry
	

	
	
	Hot
	Hot
	

	
	
	Cold
	Cold
	

	
	
	Fast
	Fast
	

	
	
	Slow
	Slow
	

	
	
	Clean
	Clean
	

	
	
	Dirty
	Dirty
	

	
	Vocabulary - Verbs 
	Sleeping
	Sleeping
	

	
	
	Climbing
	Climbing
	

	
	
	Drinking
	Drinking
	

	
	
	Riding
	Riding
	

	
	
	Eating
	Eating
	

	
	
	Blowing
	Blowing
	

	
	
	Painting
	Painting
	

	
	
	Swimming
	Swimming
	

	Cognitive Concepts


	Colours
	Red
	Red
	

	
	
	Green
	Green
	

	
	
	Blue
	Blue
	

	
	
	Yellow
	Yellow
	

	
	
	Orange
	Orange
	

	
	
	Pink
	Pink
	

	
	
	Brown
	Brown
	

	
	
	Purple
	Purple
	

	
	
	Gold
	Gold
	

	
	
	Black
	Black
	

	
	
	White
	White
	

	
	
	Silver
	Silver
	

	
	Shapes
	Triangle
	Triangle
	

	
	
	Circle
	Circle
	

	
	
	Square
	Square
	

	
	
	Rectangle
	Rectangle
	

	
	
	Sphere
	Sphere
	

	
	
	Cylinder
	Cylinder
	

	
	
	Pyramid
	Pyramid
	

	
	
	Cube
	Cube
	

	Linguistic Concepts
	Pronouns
	Show me he
	Show me he
	

	
	
	Show me she
	Show me she
	

	
	
	He is smiling
	He is smiling
	

	
	
	She is smiling
	She is smiling
	

	
	
	His book
	His book
	

	
	
	Her book
	Her book
	

	
	
	He is jumping
	He is jumping
	

	
	
	She is jumping
	She is jumping
	

	
	Linguistic Plurals
	Where are the dinosaurs
	dinosaurs
	

	
	
	Where are the ducks
	ducks
	

	
	
	Where are the balls
	balls
	

	
	
	Where are the children
	children
	

	
	
	Feet
	feet
	

	
	
	mice
	mice
	

	
	Linguistic Negatives
	Which one isn’t a sheep
	chicken
	

	
	
	Which one isn’t a toy
	coat
	

	
	
	Which plate has nothing on it
	Empty plate
	

	
	
	Who has no hat
	Child no hat
	

	
	
	Who has no food
	Child no food
	

	
	
	Who has nothing to play with
	Child no toy
	

	
	
	Look some sweets, who has none
	Child no sweets
	

	
	
	Whose sweets have all gone
	Child no sweets
	

	
	
	Who is not reading
	Child not reading
	

	
	
	Who is not eating
	Child not eating
	

	
	Linguistic Prepositions
	Which monster is on the table
	on the table
	

	
	
	In front of
	In front of
	

	
	
	Next to
	Next to
	

	
	
	Under
	Under
	

	
	
	Who is at the bottom
	at the bottom
	

	
	
	At the top
	At the top
	

	
	
	In the middle
	In the middle
	

	
	
	Has come off 
	Off
	

	
	Linguistic Tenses
	Who has baked
	Has baked
	

	
	
	Who will bake
	Will bake
	

	
	
	Who is baking
	Is baking
	

	
	
	Who is going to wash
	Is going to wash
	

	
	
	Who has washed
	Has washed
	

	
	
	Who is washing
	Is washing
	

	
	
	Who will eat their cake
	Will eat
	

	
	
	Who has eaten their cake
	Has eaten
	

	
	
	Who is eating their cake
	Is eating
	

	
	
	Who will paint
	Will paint
	

	
	
	Who is painting
	Is painting
	

	
	
	Who has painted
	Has painted
	

	
	
	Who is doing the puzzle
	Is doing
	

	
	
	Who has done the puzzle
	Has done
	

	
	
	Who will do the puzzle
	Will do
	

	
	
	Who has drunk their juice
	Has drunk
	

	
	
	Who is going to drink their juice
	Is going to drink
	

	
	
	Who is drinking their juice
	Is drinking
	

	
	
	Who has cut the paper
	Has cut
	

	
	
	Who will cut the paper
	Will cut
	

	
	
	Who is cutting the paper
	Is cutting
	

	
	
	Who is going to build a tower
	Is going to build
	

	
	
	Who has built a tower
	Has built
	

	
	
	Who is building a tower
	Is building
	

	Two word level Sentences

Information carrying word  types as indicated: 


	Noun/noun


	The book on the bed
	Book bed
	

	
	
	The book on the chair
	Book chair
	

	
	
	The brush on the chair
	Brush chair
	

	
	
	The brush on the bed
	Brush bed
	

	
	Noun/preposition


	Keys in the box
	Keys in
	

	
	
	Keys on the box
	Keys on
	

	
	
	Cup on the box
	Cup on
	

	
	
	Cup in the box
	Cup in
	

	
	Noun/adjective


	Blue ball
	Blue ball
	

	
	
	Blue pen
	Blue pen
	

	
	
	Yellow pen
	Yellow pen
	

	
	
	Yellow ball
	Yellow ball
	

	
	Noun/verb
	The boy sleeping
	Boy sleeping
	

	
	
	The girl sleeping
	Girl sleeping
	

	
	
	The boy reading
	Boy reading
	

	
	
	The girl reading
	Girl reading
	

	Three word level Sentences

Information carrying words as follows: 


	noun/noun/noun

(same distractor)
	The pen, the brush and the spoon
	Pen brush cup
	

	
	
	The phone, the keys and the ball
	Phone keys ball
	

	
	noun/noun/noun

(different distractors)
	The keys, the pen and the brush
	Keys pen brush
	

	
	
	The ball the phone and the spoon
	Ball phone spoon
	

	
	noun/adjective/noun

(colour)
	The teddy on the blue bed
	Teddy blue bed
	

	
	
	The doll on the pink bed
	Doll pink bed
	

	
	noun/adjective/noun

(big/little)
	The little teddy on the chair
	Little teddy chair
	

	
	
	The big dog on the bed
	Big dog bed
	

	
	noun/preposition/noun


	The apple on the box
	Apple on box
	

	
	
	The keys next to the box
	Keys next to box
	

	
	noun/verb/noun
	The boy eating cake
	Boy eating cake
	

	
	
	Boy reading in bed
	Boy reading bed
	




